Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

MSSQL Stored procedure : only one command executed

For a MSSQL Stored Procedure, We have used this

Solution1:

Just put SET NOCOUNT OFF in the end of the stored procedure. After that run the stored procedure in the Desktop Intelligence report.

Or

If the above doesnu2019t works then please try the following solution.

Solution2:

You have to add the given parameter in .sbo file -> save the file and run the stored Procedure.

This file should be located under <drive>\Business Objects\BusinessObjects Enterprise 11.5\dataAccess\RDBMS\connectionServer\odbc\odbc.sbo

<Defaults>

<Parameter Name="Force SQLExecute">Always</Parameter>

but it still does not work

What others?

Former Member
Not what you were looking for? View more on this topic or Ask a question