Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

How to generate a MSDS report from status GP (Generation possible) to RE

Hi EHS Goeroes,

I'm struggling with the Generation of the MSDS. I have done the following procedure and settings:

a) Create MSDS report (CG42)

b) Edit Generation Variant (CG2B)

Settings:

(I have assigned my template to the Generation Variant)

Generate manual request automatically: marked

Change Marks: 0

Initial release status: RE (released)

Version requirement: unmarked

Set historical automatically: unmarked

c) EHS > Specification Workbench > Report from Template (to test the design - display is correct and all phrases can be found)

d) EHS > Specification Workbench > Create new report

(report has been created succesfully and appears in Report Management).

e) EHS > Specification Workbench > Report Management:

MSDS_29 Material Safety Data Sheet for China World

Chinese Not Relevant Generation Poss. => generation possible.

  • Feedback affter clicking on Accept: You tried to carry out action 'Accept' on a report with status GP. However, this action is not allowed for reports with this status.

  • Feedback after clicking on Generate: You tried to carry out action 'Generate' on a report with status GP. However, this action is not allowed for reports with this status.

d) SE38 I have no jobs scheduled yet, so I run the following two programs to start the worklist manually, RC1AVGE1 and RC1AVGE2.

RC1AVGE1 - gave allot of feedback information regarding to changes and so on (first time I run it).

RC1AVGE2 - feedback: EHS: 'Worklist Generation for Reports - Selection for Check. - 0 reports to be checked were found'

From my understanding program RC1AVGE2 - should generate the MSDS.

e) WWI - monitor display (CG5Z):

100 @03\QNo background processes in client@ 5 SBR WWI-00000000000000000002 FREE RMDERKS

110 @03\QNo background processes in client@ 5 SBR WWI-00000000000000000063 FREE A132645

xxx SV001 @5B\QWWI server is active@ @02\QNo background processes on WWI server@

xxx SV003 @5C\QWWI server is inactive@ @02\QNo background processes on WWI server@

I checked if I had any jobs running in the background or has been finished, but it seems like it goes wrong here, the system does not generate a job for the generation of the MSDS_29. To be able to get the status of MSDS_29 to RE (Released).

Does anybody has an idea what I do wrong, or which settings might be incorrect? Futhermore, what are the further steps to issue the report in the SD module - report shipping?

Help is much appreciated!

Roy Derks

Not what you were looking for? View more on this topic or Ask a question