Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

PLSRV_CALL_ADAPTER, HTTP_SEND Performance issue in PI 7.0 (SP16)

Dear friends,

I have a synchronous WebService -> XI -> Proxy scenario and tried to do a stress testing this morning, when we simulate 80 client users to send the soap request to XI server, I found a performance issue that some of the request messages spent too long time, after checking the details, it's found that the run time item 'HTTP_SEND' is the major reason:

<SAP:RunTimeItem>

<SAP:Name type="PLSRV">PLSRV_CALL_ADAPTER</SAP:Name>

<SAP:Timestamp type="begin" host="JT-PIDEV">20080919023723.87111</SAP:Timestamp>

</SAP:RunTimeItem>

- <SAP:RunTimeItem>

<SAP:Name type="PLSRV">HTTP_SEND</SAP:Name>

<SAP:Timestamp type="begin" host="JT-PIDEV">20080919023723.878215</SAP:Timestamp>

</SAP:RunTimeItem>

- <SAP:RunTimeItem>

<SAP:Name type="PLSRV">HTTP_SEND</SAP:Name>

<SAP:Timestamp type="end" host="JT-PIDEV">20080919023734.474367</SAP:Timestamp>

</SAP:RunTimeItem>

- <SAP:RunTimeItem>

<SAP:Name type="PLSRV">PLSRV_CALL_ADAPTER</SAP:Name>

<SAP:Timestamp type="end" host="JT-PIDEV">20080919023734.480719</SAP:Timestamp>

</SAP:RunTimeItem>

you can find that this step spent about 11 seconds which is not acceptable, as in the normal case, it takes not more than 1 second.

From my understanding, this step will send the message to the target SAP system via the plugin http, why these messages took such long time? How can I tuning this issue?

Regards,

Bean

Former Member
Not what you were looking for? View more on this topic or Ask a question