Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

exception when run the link for exchangeProfile.

Hi all:

It is found that exchangeProfile service is not installed or not deployed on NW at least, when I check through visual admin. exchangeProfile, IntegrationServices, ExchangeDirectory, ExchangeRepository are not deployed services,

When run http://exxpi:500000/exchangeProfile, the page shows and I can maintain Connectoin parameter, and can import exchangeProfile file, but after that, when try show exchangeProfile by refresh the screen, nothing shows. (I don't know if it is a problem)

but when run the link.

http://exxpi:500000/webdynpro/dispatcher/sap.com/com.sap.xi.exprofui/XIProfileApp.

exceptions come up.

*******************************************************************************************************************

com.sap.tc.webdynpro.services.sal.core.DispatcherException: The requested deployable object 'sap.com/com.sap.xi.exprofui' and application 'XIProfileApp' are not deployed on the server. Please check the used URL for typos.

at com.sap.tc.webdynpro.clientserver.session.RequestManager.getApplicationDeployableObjectPart(RequestManager.java:383)

at com.sap.tc.webdynpro.clientserver.session.RequestManager.initTask(RequestManager.java:317)

at com.sap.tc.webdynpro.clientserver.session.RequestManager.doProcessing(RequestManager.java:143)

at com.sap.tc.webdynpro.serverimpl.defaultimpl.DispatcherServlet.doContent(DispatcherServlet.java:62)

at com.sap.tc.webdynpro.serverimpl.defaultimpl.DispatcherServlet.doGet(DispatcherServlet.java:46)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:740)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)

at com.sap.engine.services.servlets_jsp.server.HttpHandlerImpl.runServlet(HttpHandlerImpl.java:390)

at com.sap.engine.services.servlets_jsp.server.HttpHandlerImpl.handleRequest(HttpHandlerImpl.java:264)

at com.sap.engine.services.httpserver.server.RequestAnalizer.startServlet(RequestAnalizer.java:347)

at com.sap.engine.services.httpserver.server.RequestAnalizer.startServlet(RequestAnalizer.java:325)

at com.sap.engine.services.httpserver.server.RequestAnalizer.invokeWebContainer(RequestAnalizer.java:887)

at com.sap.engine.services.httpserver.server.RequestAnalizer.handle(RequestAnalizer.java:241)

at com.sap.engine.services.httpserver.server.Client.handle(Client.java:92)

at com.sap.engine.services.httpserver.server.Processor.request(Processor.java:148)

at com.sap.engine.core.service630.context.cluster.session.ApplicationSessionMessageListener.process(ApplicationSessionMessageListener.java:33)

at com.sap.engine.core.cluster.impl6.session.MessageRunner.run(MessageRunner.java:41)

at com.sap.engine.core.thread.impl3.ActionObject.run(ActionObject.java:37)

at java.security.AccessController.doPrivileged(Native Method)

at com.sap.engine.core.thread.impl3.SingleThread.execute(SingleThread.java:100)

at com.sap.engine.core.thread.impl3.SingleThread.run(SingleThread.java:170)

Caused by: com.sap.tc.webdynpro.services.exceptions.WDRuntimeException: Failed to create deployable object 'sap.com/com.sap.xi.exprofui' since it is not a Web Dynpro object.

at com.sap.tc.webdynpro.serverimpl.core.deployment.AbstractDeployableObject.<init>(AbstractDeployableObject.java:106)

at com.sap.tc.webdynpro.serverimpl.wdc.deployment.DeployableObject.<init>(DeployableObject.java:56)

at com.sap.tc.webdynpro.serverimpl.wdc.deployment.DeployableObjectFactory.getDeployableObject(DeployableObjectFactory.java:95)

at com.sap.tc.webdynpro.services.sal.deployment.core.DeployableObjectInternal.getDeployableObjectInternal(DeployableObjectInternal.java:34)

at com.sap.tc.webdynpro.clientserver.session.RequestManager.getApplicationDeployableObjectPart(RequestManager.java:380)

*********************************************************************************************************************

What 's more , LCRSAPRFC, SAPSLDAPI, connection cann't be found under SM59 .

Could you please tell me where the problem is . thank you very much !!!

Former Member
Former Member replied

try restart the server.

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question