Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

XIr2 problem with WIReportServer hanging, possibly memory leak?

We are using XIr2 (SP1) and constantly have problems throughout the day with WIReportServer processes hanging. They tend to get to about 1.8GB in size and stop responding.

If we then look at them in the CMC they show as not running (with the red icon).

We are then forced to stop and start the process using the CCM.

Any scheduled jobs running at that time against the WIReportServer in question are then lost. Usually returning with a "Transport error: Communication failure.". Also any users logged in and using the server in question lose their work.

I have tried patching our development server to SP2 fix pack 2.7 and then SP4 fixpack 4.3 and if I run a number of jobs I seem to be able to get the WIReportServer to stop responding on both of these releases.

I would say it looks like memory is not being released when reports finish but I can't be the only XIr2 user having this problem?

Even though we run some quite large reports I don't believe we are being too ambitious. We tend to only have about 20 users on at any one time. We limit our one job server to only have 5 jobs running at any one time. We run 3 WIReportServers. The hardware is not under any pressure, plenty of memory and CPU free (4 processor, 8Gb Mem). All of our reports are Webi reports and some are against SAP/BW as we use the SAP connector too.

Any suggestions or ideas would be much appreciated. Planning to move to XIr3 as soon as time allows.

Thanks

Nick

Not what you were looking for? View more on this topic or Ask a question