Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

J2ee Adapter engine installation error

Hi All,

I am installing XI with NW07. I had an ERP2005 server here with ABAP only. I installed Java Add In to it with usage type PI.

Now I tried to install J2ee adapter engine. It showed if i want to run a new installation or continue the old one.

I tried to install installation of J2ee adapter engine from a new directory.

It is stuck in between. I choose it as a MCOD to existing DB.

I can see a new instance for this in MMC and it is up and running.

But the old java instance is not running. None of the Proceses of Old Java instance (dispatcher, server0 and SDM) are not running. Did I do something wrong?

My JVM_BOOTSTRAP.OUT says this:-

Exception occurred:

com.sap.engine.frame.core.configuration.NameNotFoundException: A configuration with the path "cluster_data/dispatcher/ID4065200" does not exist.

at com.sap.engine.core.configuration.impl.ConfigurationDataCacheAllImpl.getSubConfiguration(ConfigurationDataCacheAllImpl.java:107)

at com.sap.engine.core.configuration.impl.ReadAccessConfiguration.getSubConfiguration(ReadAccessConfiguration.java:715)

at com.sap.engine.bootstrap.Synchronizer.getConfiguration(Synchronizer.java:426)

at com.sap.engine.bootstrap.Synchronizer.getElementType(Synchronizer.java:72)

at com.sap.engine.bootstrap.Bootstrap.initDatabaseConnection(Bootstrap.java:420)

at com.sap.engine.bootstrap.Bootstrap.<init>(Bootstrap.java:144)

at com.sap.engine.bootstrap.Bootstrap.main(Bootstrap.java:814)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:324)

at com.sap.engine.offline.OfflineToolStart.main(OfflineToolStart.java:81)

Exception occurred:

com.sap.engine.bootstrap.SynchronizationException: Database initialization failed! Check database properties!

at com.sap.engine.bootstrap.Bootstrap.initDatabaseConnection(Bootstrap.java:422)

at com.sap.engine.bootstrap.Bootstrap.<init>(Bootstrap.java:144)

at com.sap.engine.bootstrap.Bootstrap.main(Bootstrap.java:814)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:324)

at com.sap.engine.offline.OfflineToolStart.main(OfflineToolStart.java:81)

-


== Caused by: ==----


com.sap.engine.bootstrap.SynchronizationException: No such Dialog Instance (ID4065200) in the database! Check database consistency or local Bootstrap properties!

at com.sap.engine.bootstrap.Synchronizer.getElementType(Synchronizer.java:75)

at com.sap.engine.bootstrap.Bootstrap.initDatabaseConnection(Bootstrap.java:420)

at com.sap.engine.bootstrap.Bootstrap.<init>(Bootstrap.java:144)

at com.sap.engine.bootstrap.Bootstrap.main(Bootstrap.java:814)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:324)

at com.sap.engine.offline.OfflineToolStart.main(OfflineToolStart.java:81)

Bootstrap module> Problem occurred while performing synchronization.

My dev_jcontrol.b00 shows:-

**********************************************************************

JControlStartJLaunch: program = C:\usr\sap\IDE\DVEBMGS00\exe\jlaunch.exe

-> arg00 = C:\usr\sap\IDE\DVEBMGS00\exe\jlaunch.exe

-> arg01 = pf=C:\usr\sap\IDE\SYS\profile\IDE_DVEBMGS00_sapides

-> arg02 = -DSAPINFO=IDE_00_bootstrap

-> arg03 = -nodeId=-1

-> arg04 = -file=C:\usr\sap\IDE\DVEBMGS00\j2ee\cluster\instance.properties

-> arg05 = -syncSem=JSTARTUP_WAIT_ON_5284

-> arg06 = -nodeName=bootstrap

-> arg07 = -jvmOutFile=C:\usr\sap\IDE\DVEBMGS00\work\jvm_bootstrap.out

-> arg08 = -stdOutFile=C:\usr\sap\IDE\DVEBMGS00\work\std_bootstrap.out

-> arg09 = -locOutFile=C:\usr\sap\IDE\DVEBMGS00\work\dev_bootstrap

-> arg10 = -mode=BOOTSTRAP

-> arg11 = pf=C:\usr\sap\IDE\SYS\profile\IDE_DVEBMGS00_sapides

-> arg12 = -DSAPSTART=1

-> arg13 = -DCONNECT_PORT=4740

-> arg14 = -DSAPSYSTEM=00

-> arg15 = -DSAPSYSTEMNAME=IDE

-> arg16 = -DSAPMYNAME=sapides_IDE_00

-> arg17 = -DSAPPROFILE=C:\usr\sap\IDE\SYS\profile\IDE_DVEBMGS00_sapides

-> arg18 = -DFRFC_FALLBACK=ON

-> arg19 = -DFRFC_FALLBACK_HOST=localhost

-> lib path = PATH=C:\j2sdk1.4.2_09\jre\bin\server;C:\j2sdk1.4.2_09\jre\bin;F:\oracle\IDE\102\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\j2sdk1.4.2_06\bin;C:\j2sdk1.4.2_06\lib;C:\usr\sap\IDE\SYS\exe\uc\NTI386

-> exe path = PATH=C:\j2sdk1.4.2_09\bin;C:\usr\sap\IDE\DVEBMGS00\j2ee\os_libs;F:\oracle\IDE\102\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\j2sdk1.4.2_06\bin;C:\j2sdk1.4.2_06\lib;C:\usr\sap\IDE\SYS\exe\uc\NTI386

**********************************************************************

Thr 4232 Tue Sep 16 17:48:04 2008

Thr 4232 *** ERROR => invalid return code of process bootstrap (exitcode = 66) http://jstartxx.c 1642

Thr 4232 JControlExecuteBootstrap: error executing bootstrap node bootstrap (rc = 66)

Thr 4232 JControlCloseProgram: started (exitcode = 66)

Thr 4232 JControlCloseProgram: good bye... (exitcode = 66)

My DEV_BOOTSTRAP.B00 shows:-

Thr 5984 Tue Sep 16 17:48:02 2008

Thr 5984 JHVM_RegisterNatives: registering methods in com.sap.bc.krn.perf.PerfTimes

Thr 5608 Tue Sep 16 17:48:04 2008

Thr 5608 JLaunchIExitJava: exit hook is called (rc = 66)

Thr 5608 **********************************************************************

u2022

o

 ERROR => The Java VM terminated with a non-zero exit code.

 Please see SAP Note 943602 , section 'J2EE Engine exit codes'

 for additional information and trouble shooting.

**********************************************************************

Thr 5608 JLaunchCloseProgram: good bye (exitcode = 66)

I ran the prerequisite checks before starting the installation.

It shows everything ok except it told me to have a environmental variable as CPIC_MAX_CONV with the value 200 at least. And I did that.

All the other checks were ok.

All are on SAME OS and same machine.

I have J2EE Adapter Engine installation guide, but there is nothing for this in that

In Instance properties file for the old instance it is showing the instance ID which it is not able to find.

In the configtool of both the instances, the instance ID is same under cluster_data and this is of the newer instance

How did the instance ID and data got replaced in the configtool of old instance. I mean the new instance has its new directory or folder.

What Could be the problem?

Did I do anything wrong here?

.

Kindly help

Not what you were looking for? View more on this topic or Ask a question