Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

URL with "~" not showing when accessing portal from Internet

Hi All,

I realized that I can't get some portal objects when trying to access my portal URL from Internet.

Working fine if used within the corporate lan instead.

We noticed that icons/gif are not showed, but we realized that inaccessible objects are those which url contains "~".

We performed a comparison between internet explorer temp files when accessing from internet and internet in order to get such conclusion.

Example:

we cannot access

http://external-url.com/webdynpro/resources/sap.com/cafeugpuirtwc/Components/com.sap.caf.eu.gp.ui.rtwc.CInformationList/alertsAndWarnings.gif

we can access

http://internal-url.com/webdynpro/resources/sap.com/cafeugpuirtwc/Components/com.sap.caf.eu.gp.ui.rtwc.CInformationList/alertsAndWarnings.gif

Some webdispatcher redirect configuration:

icm/HTTP/redirect_0 = PREFIX=/, TO=/irj/index.html

icm/HTTP/redirect_1 = PREFIX=/webdynpro, TO=/webdynpro/, HOST=external-url.com, PORT=80

#icm/HTTP/redirect_1 = PREFIX=/webdynpro, FROM=/webdynpro/*, TO=/webdynpro/

#icm/HTTP/redirect_2 = PREFIX=/images, FROM=/images/*, TO=/images/, HOST=external-url.com, PORT=80

#icm/HTTP/redirect_3 = PREFIX=/logon, TO=/logon/, HOST=external-url.com, PORT=80

None of the above have succeed.

Any idea will be appreciated.

Best regards

Former Member
Not what you were looking for? View more on this topic or Ask a question