Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

R3ta on BI partitioned tables - Table names contain "/"

I am preparing for a BI Unicode conversion and am considering running R3ta on some of the larger partitioned tables. Today I ran R3ta for table /BIC/B0001949000 on our QBW system (DB2 v8 z/OS with SAP on AIX 5.3). R3ta failed for this table and I was unable to find a log file which contained the error. In sapinst_dev.log I found the call to R3ta.

./R3ta -o Split//BIC/B0001949000.WHR -t /BIC/B0001949000+5 -check_utf8 -f Split//BIC/B0001949000.STR -l R3ta_/BIC/B0001949000.log

I tried running this manually from the AIX command line as user qbwadm and nothing happened and no log files were created and nothing was written to standard out. I then figured that the u201C/u201D characters were causing the issue so I rewrote the command and escaped out the u201C/u201D with u201C\u201D in the table name and switched the u201C/u201D to u201C_u201D in the file names.

./R3ta -o ./Split/_BIC_B0001949000.WHR -t \/BIC\/B0001949000+5 -check_utf8 -f ./Split/_BIC_B0001949000.STR -l R3ta__BIC_B0001949000.log

This worked and generated a file named BICB0001949000.WHR with 5 splits that seem to match the partitioning scheme of the table.

Question: In the short term, for tables I want to split that contain a u201C/u201D I could manually run R3 on them but would be forced by AIX to change u201C/u201D to u201C_u201D in the WHR file names. If I do this, will the Migration Monitor at export/import time recognize that WHR file BICB0001949000 is for table /BIC/B0001949000? How do I proceed from here to split partitioned tables whose name contain an "/"?

It also appears that the script to validate the WHR files of a partitioned table (testwhr.sh) does not handle the u201C/u201D either. I added a debug statement to the execute_sql function in testwhr.sh and then received this.

qbwadm@adxsap52: /export/sapunicode/R3ta/downloads/testwhr

$ ./testwhr.sh.mod -db2connect ../../../sapinst/QBW/henningsR3ta/Split/_BIC_B0001949000.WHR QBWA sapadm1 BIGST0RM

/BIC/B0001949000

Database Connection Information

Database server = DB2 OS/390 8.1.5

SQL authorization ID = SAPADM1

Local database alias = QBWA

db2 SELECT count(*) AS PARTCOUNT FROM SAPR3./BIC/B0001949000 WHERE ((( PARTNO <= 5))) -- PART 1 SPLIT 1 OF 1

SQL0104N An unexpected token "/" was found following "". Expected tokens may include: "<IDENTIFIER>". SQLSTATE=42601

Error : PARTCOUNT was not found in sql return

Regards,

Tim Hennings

Not what you were looking for? View more on this topic or Ask a question