Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Problem with dashboard objects in InfoView (BOE XI 3.0 + SAP IK)

Hydro One is using an BOE XI 3.0 on IBM AIX 5.3 and Oracle 10.2.0.1 CMS DB with Integration for SAP Solutions. The InfoView, deployed on Tomcat 5.5, is accessed via SAP Enterprise Portal through URL iView. Single Sign-On is achieved by using SAP generated logon ticket to grab user information and trusted authentication mechanism. SAP EP is behind WebSeal Server and https connection has been established between EP, InfoView and WebSEAL. A junction pointing to Tomcat home page (https://<tomcat server>:<port>/) is created in WebSEAL to access BOE webapps. After logging into InfoVIew from EP, MyInfoView or any dashboard related objects cannot be created or accessed. Error message for accessing My Dashboard page shows,

https://www.onet.hydroone.com/bobj/PerformanceManagement/jsp/appsHome.js (where https://www.onet.hydroone.com/bobj is pointing to https:<tomcat server>:<tomcat https port>/) fails with syntax error u2013 Line 93, Char 1, and Object expected error on Line 265, char 23.

Same workflow works if infoview is accessed directly without EP.

Edited by: Aveek Morshed on Sep 13, 2008 5:11 PM

replied

Hello Aveek,

Is your Tomcat already configured for HTTPS? Without using EP, are you able to connect to Infoview using HTTPS request?

If so then passing the MYSAPSSO2 token from EP request to CMS should be seperate from SSL. Just make sure your EP server and Tomcat are in the same domain to pass the token successfully.

Also make sure that Infoview is configured with the following 3 parameters: single signon is true, Siteminder is false and security plugin is SecSAPR3. This is done in the web.xml of Infoview on Tomcat server.

thanks,

Mike

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question