Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Crystal Reports 2008 (v12) Runtime on X64

I have been having some serious problems trying to view reports on my Vista x64 machine with CR2008 SP0. I have done an insane amount of testing with no good results.

The error is the typical one that says you either have the wrong key code or the wrong runtime.

At the request of an engineer on CR2008, I am posting my test procedure with results each step of the way.

This is a new computer that had no previous versions of anything on it. Vista x64 Ultimate with SP1, VS2008 SP1. That's it.

-


Uninstall CRBasic SP1

Uninstall CRBasic

Uninstall CRBasic x64 runtime

Install CR2008 SP0 (options: English only, typical installation) (remember DEP is permanently off)

  • Results

- As before, designer is now working inside VS2008

- Cannot view reports in debug mode or at runtime. Same error as always - reg key permissions or incorrect runtime

Install Runtime (CRRuntime_12_0_mlb)

(Note, I never know what to put into the product id prompt. I just stick the keycode in there. But I donu2019t want to give my keycode out to my clients. I need to have them install the runtime so they can run this new version of my reports. What do I do?)

*Results

- I still cannot view reports. This is really aggravating. This is on the development machine where CR2008 is installed. I shouldnu2019t even need an additional runtime should I? Is this an x64 problem? I thought SP0 made that go away. Is it really the keycode? I used my keycode to install CR2008. Is there something in the registry I should be checking?

Install Fix Pack 1

*Results

-no change in debug or from the compiled app

Install Fix Pack 2 (there is no info anywhere about this FP. Is it cumulative (including FP1)?

*Results

-no change in debug or from the compiled app

Reinstall runtime just in case

I see the whole thing is going into program files (x86).

Looked on website and saw a NEW runtime was uploaded 3 days ago.

Uninstalled prev. runtime.

Installed latest runtime

*Results

-no change

Rebooted (there are no prompts suggesting this)

*results

-No change

Not what you were looking for? View more on this topic or Ask a question