Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

RFC Adapter Settings.

Friends ,

I am working on a RFC to XI to Mail senerio. 2 diff adapters are required for this, as we know. From r3 perspective, I have a se38 program to run the RFC.

see the code below!

report zrfc_adapter.

data: it_final1 type standard table of zrfc_str.

*Cns :

call function 'ZRFC_XI'

  • EXPORTING

  • bill_doc = 'ABCD'

tables

it_final = it_final1.

Clear it_final1.

Refresh : it_final1.

The FM has been made RFC by selecting the Remote Function Call in

FUNCTION ZRFC_XI.

*"----


""Local Interface:

*" TABLES

*" IT_FINAL STRUCTURE ZRFC_STR OPTIONAL

*"----


it_final-NAME = 'Arnab Mondal'.

it_final-TELEPHONE = '12345'.

it_final-ADDRESS = 'abcdxyz'.

append it_final.

ENDFUNCTION.

Now there is a setting needed in sm59. I hav read several blogs and wikis, and every where they are asking to make a TCP/IP connection where I hav to make a program ID . The program ID name can be 'anything'

Now friends I have done this, and select the activation type as Registered Server Type.

Then as per the snote : 730870 ,page 13, " To check which Program IDs are registered at the SAP Gateway the

gateway-monitor can be used via transaction SMGW. Select Goto ->

Logged on Clients. Registered RFC-Servers have a System-Type of

'REGISTER_TP'. The Program ID of the registered RFC-Servrer can be

found in column 'TP name'. Unfortunately the list within SMGW only

shows the truncated version of the Program ID (column 'TP name'). To

get the full name, the details of an entry have to be selected. As an

alternative the report RSGETALL_REG_SERVERS can be executed in

transaction SE38. The output of this report will show the full names

of the Program ID in column 'Registered PROGID'. This functionality is

also available in the function module GWY_READ_CONNECTED_SYSTEMS which

can be executed in transaction SE37.

So as per instruction when I tried to execute the program RSGETALL_REG_SERVERS, I couldnt find it in se38.

Now the biggest query is sm59 is not taking any arbitary PROGRAM ID name!

I tried to copy a standard tcp/ip connection: GFW_ITS_RFC_DES and the program id in this is IGS.DTR, which is working perfect. I can copy and use this,, but this is not the solution. Pls some1 help me, where am I going wrong???

Thanks and Regards,

Arnab

PLs Help !!!

Arnab

Edited by: Arnab Mondal on Sep 10, 2008 7:39 AM

Not what you were looking for? View more on this topic or Ask a question