Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

crystal reports 10, not exporting csv properly

I have a crystal report that is used to format data from a sql2k database and a flat file. After the data is formatted it is normally exported to a csv file for import into our erp system.

The report was working fine until we patched the erp system. The ERP system utilizes some internal reports that rely on crystal reports 11 version 2. After the client where crystal 10 is located was patched (ERP), the application required the CD before the crystal 10 reports could be used for exporting. The data exports fine to excel and I can save the excel file to a csv and life is good. When the report is directly exported to csv from xtal two records are combined into one. I have half a mind to do everything in excel and scrap xtal but if someone has a way to keep me from doing an extra step or recreating the wheel I would be grateful. Please keep in mind that I am fairly new to xtal as I have inherited it.

I have applied service pack 6 with no improvement. Started with version 10.0.0.533 after service pack 10.05.1506.

Former Member
replied

OK, so the group header information is repeating for each record. This is by design but there is a note (formerly kbase article) that details how to prevent this. Just search for 1196142.

The note is written for Page Headers repeating for each record and as your are only concerned about Group Headers repeating skip the first step and go directly to creating the registry key.

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question