Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Cannot retrieve data using Crystal Report 2008

Spec:

Local machine - Windows XP (SP3)

Crystal Reports 2008 v12.0.0549

SalesLogix v6.2.01474 (front end)

Miscrosoft SQL Server 2005 (back end)

Hello,

I have just installed CR2008 onto my local PC and I am retrieve any data when running old reports (either written in CR 8.5 or XI) or writing new reports.

When connecting via OLE DB, I am able to see the tables, views and the fields within them, but I cannot browse the values. One quirk I've noticed is that when I complete the Connection Information form (Data Source, User ID, Password, Database), I do not get any choices in the Database drop-down menu. I manually type this in. Adding fields into the report and refreshing the data doesn't return any values.

When loading an existing report, any saved data in the report is displayed, but when I refresh the report I get a series of messages saying:

"The database file "ONA" has changed. Proceeding to fix up the report." (where ONA is a table on the database). I click OK and it states:

"The databse is now up to date." On clicking OK here CR2008 says it's Accessing Database in the status bar. After a minute or so CR2008 crashes with Windows bringing up the message:

"crw32.exe has encountered a problem and needs close. We are sorry for the inconvenience."

I previously ran CR8.5 on this machine connecting to the database, which worked well and my colleague uses CR XI without any problems too.

Thanks in advance for any help anyone can offer me.

Tim

Former Member
replied

Tim,

You might want to download an OLEDB querying tool such as QTADO from http://home.att.net/~gpoulose/ and see if you are able to run any queries against your db there, specifically against the ONA table.

Also, what happens if you try an ODBC connection?

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question