Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Problem using Field symbols

Hi All,

We have recently upgraded to ECC6.0 and one of the zprogram is giving dump now. Previously with 4.6C it was working fine. Can someone please help me.

I researched prvious posts but did not find any answer.

Thanks,

Veni.

Runtime Errors GETWA_NOT_ASSIGNED

Short text

Field symbol has not yet been assigned.

What happened?

Error in the ABAP Application Program

The current ABAP program "SAPLKKBL" had to be terminated because it has

come across a statement that unfortunately cannot be executed.

----


  • FORM GEN_FIELD_OUT2 *

----


  • ........ *

----


form gen_field_out2.

field-symbols <l_initial>.

case gs_out-field_colcount.

when 001.

if gs_out_flags-slave ne 'X'.

>>>> assign <fm01> to <field>.

gs_fc = gs_mfc01.

else.

assign <fs01> to <field>.

gs_fc = gs_sfc01.

endif.

when 002.

if gs_out_flags-slave ne 'X'.

assign <fm02> to <field>.

gs_fc = gs_mfc02.

else.

assign <fs02> to <field>.

gs_fc = gs_sfc02.

endif.

Tags:
Former Member replied

Hi,

I would do the following...

**Comment the checkbox column in the field catalog.
**Add checkbox to the Field Catalog
*    CLEAR w_fieldcat.
*    w_fieldcat-fieldname = 'CHECKBOX'.
*    w_fieldcat-checkbox = 'X'.
*    w_fieldcat-key = 'X'.
*    w_fieldcat-outputlen = 2.
*    w_fieldcat-seltext_l = 'Selection Indicator'.
*    w_fieldcat-col_pos = 1.
*    w_fieldcat-edit = 'X'.
*    APPEND w_fieldcat TO t_fieldcat.                        " index 1.

** Add the checkbox as the box field name in the layout.
  g_layout-box_fieldname = 'CHECKBOX'.

Thanks

Naren

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question