Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Problem making connection with Business Connector 4.8 on Server 2003

We are testing Business Connector 4.8 on Windows Server 2003 R2 and cannot establish a connection with R/3. When we submit the listener we get the following error:

Error com.sap.conn.jco.JCoException

Message Server startup failed at Thu Sep 04 09:55:56 PDT 2008. This is caused by either a) erroneous server settings, b) the backend system has been shutdown, c) network problems. Could not start server: Connect to SAP gateway failed Connect parameters: TPNAME=SAPBC3 GWHOST=SAPR3DV GWSERV=sapgw00 LOCATION CPIC (TCP/IP) on local host with Unicode ERROR service '?' unknown TIME Thu Sep 04 09:55:56 2008 RELEASE 711 COMPONENT NI (network interface) VERSION 39 RC -3 DETAIL NiErrSet COUNTER 5

Key JCO_ERROR_SERVER_STARTUP

Group 129

We tested the same connection running on Windows XP SP3 and it was successful.

Any assistance would be appreciated.

Former Member
Former Member replied

Hello,

look at that:

"host with Unicode ERROR service '?' unknown TIME Thu Sep 04 09:55:56 2008 "

This means BC tries to resolve the service sapgw00 to a port name, but does not find it in your windows drivers/etc/services file. Define it there the following way:

sapgw00 3300/tcp

This problem occurs when you install BC on a naked OS with no other SAP installation (e.g. SAP GUI).

CSY

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question