Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Errors

I'm sorry if my subject line is vague but I don't know what else to call it.

I've searched the forums for my problem but I haven't found any topics that address it.

I am new to Crystal Reports and had successfully created a report that could be reused for a monthly invoice. I use Excel spreadsheets and I have data for each month on a different spreadsheet.

I created a new invoice using my December spreadsheet and it works great. However, when I try to use the January spreadsheet I get an error, which reads: "More than one datasource or a stored procedure has been used in this report. Please make sure that no SQL Expression is added and no server-side group-by is performed."

I'm sure I'm not using any SQL, although there are total fields in the report. Also, when I use the set database location function I get this error: "Some tables could not be replaced, as no match was found in the new data source. Please specify the table required for any unmodified tables."

I'm frustrated because all the spreadsheets are laid out identically.

Please help.

Former Member
replied

Hi David

I apologize for the linking question. I tried replicating the issue on my machine by creating a report using spreedsheets. I created two different spreedsheets having same data structure and I was able to update the datasource location without any issue.

Can you please let me know the exact workflow that you are using?

Thanks

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question